node-rssをインストールできるようにした。

公開:2017-01-31 21:31
更新:2017-07-29 13:18
カテゴリ:コンテンツの修復と整理

昨日node-rssのインストールができない件だが、調べるとpackage.jsonに書かれている依存ライブラリ、libxmljsのバージョンが古いせいだということが分かった。なので、node-rssをforkしてpackage.jsonを書き換えた。

  "dependencies" : {
    "libxmljs" : "0.15.x"
  },

  "dependencies" : {
    "libxmljs" : "0.18.x"
  },

を変更するだけである。 いちおうforkして修正したものを置いておく。

https://github.com/sfpgmr/node-rss

インストールは

npm install https://github.com/sfpgmr/node-rss.git

でできる。

しかしこのライブラリ、そんなに時間がかからず自作できそうな気がする。libxmljsを使えばね。